Issue
Vista Server restore database fails
Product Line
TAC Vista
Environment
Vista Server
Cause
- The Restore Database function will not work on the database directory that Vista is currently using.
- The restore is being performed on a directory that has files that are flagged as read only.
- The backup file may be incomplete.
- The backup file may be corrupt.
Resolution
If the Vista Server restore database function is not restoring the database then it is probably one of the problems listed below.
- The Restore Database function will not work on the database directory that Vista is currently using. To restore to your normal database directory, use Server Setup to point Vista Server to a different database directory. Then start Vista Server and perform the restore.
- The restore is being performed on a directory that has files that are flagged as read only. These files cannot be written over until this flag is removed. This can be caused inadvertently with database transfer as described in Transferring a Vista Database from one computer to another.
- The backup file may be incomplete. Maybe it was copied to portable media (CD, USB drive, etc.) before it was finished. To test whether the database backup file is incomplete, restore to an empty directory and open it with Vista Server to examine it for missing objects or to see if it launches at all.
- The backup file may be corrupt. This is the case if the following error message (or similar - this is from a Spanish system) is seen:
The database MAY be salvageable. Send the backup file to PSS who will attempt to fix it, with help from R&D. There are no guarantees - only do this if you have no other recent healthy backups to restore. It is always recommended to take regular backups.