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Values are indicating [??787] in Workstation.

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Values are indicating [??787] in Workstation.

Picard Product_Support
‎2018-09-06 02:23 PM

Last Updated: Guinan RobertAndriolo Guinan ‎2021-12-05 03:32 PM

Issue

Point values are not displayed in Vista Workstation.  Instead, all of them say [??787].

Product Line

TAC Vista

Environment

Vista Workstation

Cause

The most common cause of the ??787 error message is a mismatch in the XIF between the device and the Vista database.  It may also be duplicate SNVT names in the XIF.

Resolution

There are a few common troubleshooting techniques that have been applied successfully to the ??787 error and resolved the issue.  The first is to upload parameters from the device.  The second is to browse the correct XIF to the device to eliminate any mismatch.

Upload parameters

  1. Right-click on the device in Vista Workstation.
  2. Select Upload Parameters.
  3. Shut down Vista and restart.

Make certain you are using the correct XIF

  1. The only way to be absolutely certain that the XIF in the device matches the one in the database is to upload the XIF from the device.  You may need to create a dummy LNS database to do so.  Add a generic device and commission with the option to upload the XIF from the device.
  2. Update the Vista database.  Again, this may need to be a dummy Vista database.
  3. To obtain that XIF, right-click on the device in Workstation and select Properties.  The XIF File tab lists the database copy of the XIF file (hexadecimal file name) that can be found in the Vista database directory in the $thisfil folder.

Browse the correct XIF into the Vista Workstation

  1. If you are certain you have the correct XIF, right-click on the device in Vista Workstation.  Select the XIF File tab.
  2. At the bottom under Source File, click the "..." button and browse to the XIF file.
  3. Click okay.  Log out of Workstation and log back in to see the changes take effect.
  4. It may then be necessary to right-click on the controller and select Commission and Download.

Remove duplicate SNVTs

  1. Open the XIF in a word editor (Notepad, Wordpad)
  2. Find the duplicate SNVT name using the Find feature
  3. Rename one of the SNVTs to a unique name.
  4. Use the above steps to browse this new XIF into Vista Workstation.

XIF file contains internal variables

  1. Open the XIF in a word editor (Notepad, Wordpad)
  2. Search for the variable whose value displayed as [??787]
  3. If the variable is not listed in the XIF file, it is possible that this is an internal variable which Vista cannot read a value from
  4. Contact the manufacture of this device and ask if they can expose the value with a network variable in order for Vista to read it.
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