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Valid access events are not logging or showing in the active event view but Invalid events show

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Valid access events are not logging or showing in the active event view but Invalid events show

Picard Product_Support
‎2018-09-10 05:23 AM

Last Updated: Admiral David_Kendrick Admiral ‎2023-06-20 07:31 AM

Issue

On a working system, valid access events no longer show in the active event view and are no longer visible in the accessevent table within the Database.   However, invalid events continue to work normally. 

Product Line

Andover Continuum

Environment

  • Access Events
  • Logging

Cause

An incomplete object may have been added to the Continuum Database recently that is interfering with queries running against that database.

Resolution

Try the following steps to troubleshoot the issue

  1. Does the issue happen on multiple CyberStations?
  2. Ensure all the event types are selected in the active event view that is being used on the door(s).
  3. Perform a CyberStation Teach

    It is best to contact PSS and work with them at this point with the following procedures.
     
  4. Verify that access events are being sent from the controller to the CyberStation using Wireshark.
  5. Verify that the issue follows the Database by loading the database in a test environment to see if the issue still happens. 
  6. On the TEST database, use SQL Management Studio:
    1.  SQL Query: set acdbversion=0  (execute the query)
    2.  Update database: launch Database Initialization Server/Stand Alone
  7. Enter sa password and update database
  8. Restore database or locate incomplete object
    1. The quickest fix would be to revert to a known good database. Once restored, the events in the controllers would be downloaded to the database.
    2. Finding the object in the database that has caused the issue can be very challenging. Check to see if there was a controller recently added and if the issue began to happen after that. If for some reason a controller had been added and it wasn't completed normally then it could cause this issue.
    3. Check to see if there is a controller in the InfinityController table with an objectidhi or objectidlo with a zero value. If so, delete that controller and see if the valid access events start coming in.

It may also be necessary to use the SQL profiler to view the entries that are being made into the database. See the following link  below for  more information. http://msdn.microsoft.com/en-us/library/ms181091.aspx

 

NOTE:

Turning off the Primary and Secondary Access Server will cause the access events to buffer in the controllers, so that these events will be inserted into the database once valid access event logging has been restored. After turning off the primary and secondary, check the Access Log infinity system variable on the controllers. If they are non zero values, then events are buffering. There is a limited amount of access events that can be stored in the controllers before loss of data occurs.

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