Issue
Unable to view rooms with Screenmate. After logging in and typing a room number, Screenmate takes a long time searching for the room and eventually times out.
Product Line
TAC Vista
Environment
- TAC Vista 5.1.X
- Screenmate 5.1.X
Cause
This may be caused by slow network communication if Vista is running on a number of networks on a node. Vista will check all nodes for the given Screenmate ID and this can take a long time if there are a lot of objects and/or nodes.
Resolution
To resolve this issue it is possible to activate a caching function that collects the names of all the available Screenmate objects on all the nodes and stores them in a cache file. This means that the next time a user tries to view a room Screenmate will check in the cached file instead of asking all nodes for their Screenmate objects. To activate this function do the following:
- Locate the web.config file for TAC Vista web
- By default this is in c:\inetpub\wwwroot\TACVistaWeb51X\
- Open the file (with notepad) and locate the key TAC.WebStation.ScreenMate.CacheEnabled
- Change the value of this key to "True" and save the changes to the file.
- Create the cache file
- Open a web browser and type in Localhost/ScreenMate
- Try to browse to a room once logged into Screenmate. This will create the cache file.
- Check under C:\Windows\Temp and see that a file named ScreenMateCache.dat has been created.
- If the file isn't created:
- Temporarily delete the other Vista nodes in Vista workstation so that only the master is left.
- Rerun the steps above - this will create a file containing the local screenmate objects and speed the process up.
- Add the other TAC Vista nodes again and repeat the steps above shown under "Create the Cache File".
The next time the process should be much quicker, once this file is created.
If problems persist check the authority settings described in The ScreenMateCache.dat file is not created on a Windows 2008 server.