Issue
Despite using valid credentials at the Web Client login screen, the attempt fails with no error being shown and the user is dumped back to the login screen once more.
These login failure events can be seen in Windows Logs with the error 'Too many connections'
Event Viewer > Applications and Services Logs > Schneider Electric Security Expert
Product Line
EcoStruxure Security Expert
Environment
- Security Expert Server
- Security Expert Web Client
- Security Expert SOAP Service
Cause
When the SOAP service attempts to connect to Security Expert it performs an Operator login to the Data Service, pulls/pushes the information it needs, and then closes the connection. If all concurrent Operator Logins are already in use (with Thick Client connections for example) SOAP will not be allowed to log in, and any services requiring the SOAP connection will not work.
The specific operators that are consuming the licenses can be seen once again in Windows Logs
Event Viewer > Applications and Services Logs > Schneider Electric Security Expert
An Operator Logging on is shown as a 'New Operator Logon' Event (Concurrent Client + 1)
An Operator Logging off is shown as a 'Remove Operator by Disconnect' Event (Concurrent Client - 1).
Resolution
If all the Client Connections are being consumed with Thick Client logins etc, then reduce the number of connections that are logged in at any given time or purchase an additional concurrent client license SX-CLNT so there is always one free for SOAP to use.
Note:
SOAP will only use one concurrent connection even if it has multiple services connected to it, so you would not need multiple client licenses if you had Web Client, Data Sync, and EWS, for example.