Issue
What should be considered when prepairing for upgrading to Niagara 4.10?
What known issues should I be aware of when upgrading to Niagara 4.10 and how can I prepair for them?
Product Line
TAC IA Series
Environment
- I/A Series N4 Enterprise Server
- I/A Series N4 Jace 8000
Cause
Define potential issues with an N4.10 upgrade
Resolution
The following details a set of upgrade considerations and known issues and their workarounds regarding Niagara 4.10. Please review prior to upgrading to Niagara 4.10.
Niagara 4.10 and Default NRE Memory Changes:
The increased size of some core libraries in Niagara 4.10 required changes to the default NRE Memory Pool settings for use on a JACE-8000. MetaSpace memory needed to be increased to allow applications to run without issue.
Note: any previous custom memory configuration applied to the JACE-8000 will be reset upon upgrade to 4.10. Prior to upgrading your JACE-8000, please review Default NRE Memory Pool Configuration Changes In 4.10.
Niagara 4.10 System DB Upgrade:
In Niagara 4.10, we upgraded SystemDB from Orient v2 to v3, and as a result of that change, any customers that are utilizing SystemDB on their Supervisor stations will need to re-index accordingly upon upgrading to 4.10.
Please note, re-indexing can take a considerable time upon upgrade, and the DB will not have accurate information when queried until the index is complete accordingly. Prior to upgrading your Supervisor, please review System DB Must Be Re-indexed for Upgrades to Niagara 4.10+ from Earlier Niagara.
Niagara 4.10 and Third-Party Modules
Keeping your Niagara installations safe and secure is our highest priority. In Niagara 4.10, ALL third-party modules must be signed with either a trusted valid certificate or a self-signed certificate to successfully run on a station. This new policy greatly increases the security posture of Niagara installations by making administrators aware of any modules that may have been tampered with, compromised or derived from untrustworthy sources.
Niagara's new signature enforcement feature is being rolled out over multiple Niagara releases. The first iteration was built into release 4.8 to give developers adequate time to make the transition to always signing any third-party modules.
Niagara 4.8 produced console and Security Dashboard warnings about unsigned modules but allowed them to run on a station. As of Niagara 4.10, unsigned modules will not execute.
For more information, please review the Niagara documentation on Third Party Module Signing
Niagara 4.10 Updated Operating Systems, Browsers, and Databases
For the latest information on supported operating systems, please refer to Supported OS and other software in the Niagara 4 Framework Installation Guide.
Tridium remains focused on keeping pace with advancing IT infrastructure to enable more efficient, long-term support of each release version. This policy enhances the security posture of a Niagara installation by ensuring that only the most robust, secure operating systems and enterprise applications are compatible with the framework. The list below provides information on what we will be supporting with Niagara 4.10.
OS, Browser, Database | Version |
Red Hat Enterprise Linux | 8.1 (64 bit), 7.7 |
Windows | Server 2019 (64 bit), Server 2016 (64 bit), Windows 10 (64 bit) |
VMWare | ESXi 6.7 |
Oracle Database | 19.3, 18.3, ... 12.2/12.1 |
MySQL Database | 8 |
MS SQL Database | 2019, 2017, 2016 |
Browsers | Chrome, FireFox, Microsoft Edge |
Mobile Browsers | Safari (iOS 12, 13), Chrome (Android 8, 9, 10) |
As with all software products, we must also deprecate support for some operating systems and enterprise applications. Nevertheless, you can be confident that the above list will handle your needs moving forward.
Using Web Launcher with Niagara 4.10
Web Launcher 20.4.2 was recently revamped for Niagara 4.10 to include essential software dependencies updates along with critical defect fixes. This version of Web Launcher has Java version 8 update 275 and certificate management has been updated to work with Niagara 4.10 along with any legacy or prospective release.
Prior to using Web Launcher with Niagara 4.10, the customer should update Web Launcher accordingly (see steps below).
Updating WebLauncher
Web Launcher has a feature to check for updates over the internet and prompts the user when a new version is available in the cloud. However, the existing version of Web Launcher has a bug that prevents a smooth update. Users will be required to perform a fresh install by downloading the latest version from the cloud via the station web Login page.
- Click on the Niagara Web Launcher Installer link on the station's Web Launcher Web Page, which can be reached via the link on the Login page itself.
- Once the download is successful, click on the msi file and follow the installation wizard.
- You do not have to uninstall the older version. The new installation will automatically update to the latest version.