Issue
There is a problem after upgrading the SystemDB to N4.10.
Product Line
TAC IA Series
Environment
- I/A Jace 8000 N4.10
- I/A Enterprise Server N4.10
Cause
In Niagara 4.10, we upgraded SystemDB from Orient v2 to v3, and as a result of that change, any customers that are utilizing SystemDB on their Supervisor stations will need to re-index accordingly upon upgrading to 4.10.
Resolution
In Niagara 4.10, the SystemDB has been upgraded from Orient v2 to v3. Because of this change, customers that are utilizing SystemDB on their Supervisor stations will need to re-index upon upgrade to 4.10. Please note, re-indexing can take a considerable time upon upgrade, and the DB will not have accurate information when queried until the index upgrade is complete.
After upgrading to 4.10, invoke the actions that force system indexing. Be aware that re-indexing can take some time, and that the DB won’t have accurate information when queried until the index is complete.
The following image shows how to invoke execute on the Local System Indexer:
If the Station has a DB configured to contain information about points on other stations, the Niagara Network System
Indexer should be used, rather than the Local System Indexer. Additional details regarding indexer actions can be found in the Niagara System Database and System Indexing Guide.