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Seeing an error when attempting to log in to Security Expert Web Client.

Picard Product_Support
‎2018-09-10 09:54 AM

Last Updated: Kirk AdamSteele Kirk ‎2022-04-28 06:57 PM

Issue

When attempting to login to Security Expert Web Client the below error is seen.

  • The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.

Product Line

EcoStruxure Security Expert

Environment

Security Expert Web Client

Cause

The typical cause of this error is a mismatch in the security bindings between the SOAP Service and the Security Expert Data Service. For example if you enable the Windows Authentication checkbox in the Security Expert installer but not in the SOAP Service installer (or vice versa) then you have a mismatch.

Resolution

Either uninstall the SOAP service and update the checkbox selection to match whatever was selected in the Security Expert installer, or follow the instructions under Troubleshooting | Communication Fault/Failure in the SX-WEB - Security Expert - Security Expert Web Client - Installation Guide for editing the config files of the SOAP service to match the Security Expert Data Service.

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