Issue
Security Expert Data Service fails to start with error 1067: The process terminated unexpectedly
Product Line
Security Expert
Environment
Security Expert Server
Cause
- Port used by the service is blocked or already in use
- Permission issues with the service logon account
- Prerequisite .NET Framework is incomplete or not installed correctly
Resolution
- In Windows go to Windows Features and ensure that all .NET Framework items show a check mark to indicate that each sub item has been enabled. See Ensuring Windows features are installed for Security Expert SOAP service for details.
- In Windows Event Viewer, examine the Application log, it will typically have an entry with details about the reason for the error.
In this case, we see an Address Already In Use Exception in the Socket Connection Listener. This is a clue the error is with the network port. The Security Expert data service has been configured to use the default port 8000.
- On the server, list the network ports using netstat.
We can see PID 5660 is already using the port. - Get the name of service associated with PID 5660.
- Once the service is identified, take corrective steps to ensure the two services don't use the same port.
- Make sure the Windows account the service is using to log on has the appropriate permissions.
- If port 8000 isn't being used, first Reboot the Security Expert PC and if the error still persists, uninstall Security Expert, reboot and reinstall.