Issue
- Security Expert Client crashes when attempting to browse to the Status Page Editor.
- Unable to create Status Pages for system monitoring.
- When viewing Status Pages none are shown and the word "Frame" is displayed in the view.
Product Line
EcoStruxure Security Expert
Environment
- Security Expert Client
- Status Pages
Cause
The problem is due to the site database not containing the default id=0 objects. As there is no id=0 Status Page for your site, the Client crashes when browsing to Monitoring | Setup | Status Page Editor. This can occur when the original 'default controller' is not created during initial Site configuration. A number of default objects are also created as well as the first controller.
If you look at the site database, you will also find that it does not contain any id=0 Event Filters or Actions which means that no events will be logged either.
Resolution
There are two options to resolve these missing default records:
- Start with a new Security Expert database and ensure that when creating your Site that the first 'default controller' is created with the Controller Wizard (when prompted). At the end of this process, the default id=0 site objects will also be created.
- Raise a case with Product Support to arrange for a remote connection. PSS engineers will then attempt to create the missing id=0 records retrospectively. The site's SSN may need to be provided..