Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
Project Configuration Tool generates a 'failed get matching version' error when attempting to start an existing server
Product Line
EcoStruxure Building Operation
Environment
Project Configuration Tool (PCT)
Cause
The associated PCT server package files are not installed, cannot be accessed or are corrupt
Resolution
The "get matching version error" can occur when the associated server package files are not installed, cannot be accessed or are corrupt. Try the following steps:
- Check the associated PCT server package is installed, click manage packages (1) and check the Manage packages window (2)
- Install the package if it is missing and then attempt to start the server
- If still unsuccessful, reinstall the server package and then attempt to start the server
- When installing the package if the error below occurs navigate to 'C:\ProgramData\Schneider Electric EcoStruxure\Building Operation\Project Configuration Tool\logs' and open the ConfigurePCT.log file to try and identify the problem
- In the case the server package config file is corrupt navigate to the server packages folder at 'C:\ProgramData\Schneider Electric EcoStruxure\Building Operation\Project Configuration Tool\external\VM\cfg' and delete the associated *.cfg file.
- Reinstall the server package and then attempt to start the server
- Additionally consult PCT error installing EBO package for further suggestions