Issue
What is the password recovery procedure for the SpaceLogic Operator Display if the password is lost?
Product Line
EcoStruxure Building Operation
Environment
SpaceLogic Operator Display
Cause
If losing the password for the SpaceLogic Operator Display there is no password recovery procedure available to recover it.
The only option to access the device again is to do a device recovery procedure on the device.
When doing a device recovery on the device everything on it, all users, configuration data, and logs will be deleted and a new firmware loaded into the device
Resolution
Steps to perform a device recovery procedure:
- Download the device recovery file (tar.gz file) which is included in the “SpaceLogic Operator Display HMIST6400SL Firmware Package” which you can download from Schneider Electric Exchange
- Extract files and copy them to a USB stick (Format: FAT)
a. Unpack the tar.gz
b. Two unpacks are required, then "aurora" folder should be present
c. Copy whole "aurora" folder to a USB stick
d. The structure on disk should be:
e. aurora (folder)-FIRMWARE (folder)- AURORA.CFG-nand.img - Power off OPD (Operator Display)
- Connect a USB-OTG cable (On-The-Go cable, USB-micro-B to USB-A) to the USB-2 port on the rear of OPD . Note: The cable is like a key, to enable device recovery. Do NOT connect USB stick to cable.
- Connect the USB stick to the USB-1 port on the rear of the OPD
- Power on OPD
- Device will boot to a white screen and display: Recovery Mode Loading nand.img... Writing KERNEL... Writing ROOTFS... Udisk upgrade success! (Loud beep) "Upgrade successfully, Wait to Reboot!"
- Power off OPD.
- Remove USB stick and USB-OTG cable
- Power on device and it will boot to the loaded firmware
- Firmware version is shown on startup screen.
For more details see video: