Issue
How to upgrade remote MPMs with a Canbus, Zigbee network.
Product Line
EcoStruxure Building Expert
Environment
SmartStruxure Lite Multi-Purpose Manager MPM
Cause
Cannot connect to an MPM directly to perform a firmware upgrade
Resolution
This procedure explains how to perform a firmware upgrade on multiple remote devices at once, in order to save time and standardize the firmware versions across your deployment. This process will induce traffic on the network, therefore it is recommended that this procedure be performed after-hours or when it is less likely to disrupt normal operations.
Step 1: Verify your monitor Manager's firmware version
Ensure monitor MPM has the same or higher firmware version than the the version intended to be installed on the remote MPMs. Highlight the MPM in the Network Panel on the left side of your screen and either click on the "About" button or navigate to CFG1 object to verify firmware version.
Step 2: Download and rename the firmware file
The firmware can be downloaded from the Exchange then firmware file must be renamed "upgrade.bp"
Step 3: Upload the firmware file to your Manager
Choose the File Manager tab and click on the “Upload File” icon. A dialog box will open to select the firmware file on your local PC.
Browse to the correct file and select it. Click the “Upload” button to send the file from your computer to the controller.
When the file upload is completed, the file will be shown in the Upload Manager list.
Step 4: Initiating the remote upgrade
Inside the File Manager panel, either right-click on the firmware file that was just uploaded and select “Add to all” to copy the same file to all the remote nodes, or drag and drop the file from the left panel onto the desired Manager on the right panel. The file will be displayed under each of the remote nodes (or a single node if the file was copied using drag and drop) under the Network panel, on the right side of the window.
In order to initiate the file transfer to the remote nodes, click the Start button. The status will change to “In Progress” and you will be able to follow the progress of each node in the Network panel. Once the file transfer is complete, the remote nodes will reset and perform the firmware upgrade.
Step 5: Verify the firmware version of the remote nodes
You can verify that the upgrade process completed successfully by highlighting the remote node in the left panel and then select the “Controller Configuration” (CFG1) object. The version # will be displayed in the bottom section.