Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
I/NET transitioned User ID Credentials that have non-numerical characters (like a dash "-") cannot be modified in the Security Expert Client
Product Line
EcoStruxure Security Expert,TAC INET
Environment
Security Expert Controller
Cause
Security Expert Client does not allow User ID Credentials with non-numerical characters with a dash (-) to be modified
Resolution
Method 1:
- Delete the dash from the User ID Credential the first time you need to make any other edit to that user in SX.
- Click Save.
Method 2:
- Make a backup of the existing SX database in case you want to restore what you had.
- Use the latest version of the INET Database Transition Tool to re-transition ONLY Users.
Note: Any adjustments you've made to the User's Access Levels in SX since the original transition from INET will be lost. You will need to make those adjustments again.