Issue
Master / Slave schedules not working
Product Line
TAC IA Series
Environment
I/A series R2 Niagara
Cause
When Master / Slave schedules not functioning properly the most common cause is an issue with the Address books.
Another issue that can cause this is the firewall application on the Enterprise Server computer.
Resolution
To confirm it is an Address book issue conduct the following test:
- Create an AO object in the Master device (typically the Enterprise Server) and the Slave device (typically the UNC).
- Link the output of the AO in the Master device to the input of the AO in the Slave device.
- Link the output of the AO in the Slave device to the input of the AO in the Master device.
When viewing the AO's at each station in the WorkspaceEditor there should be little boxes on both sides of each AO indicating both devices can send and receive data.
If an Address book issue exists there will be a box missing at one device or the other. To correct this issue:
- Reboot which ever station only shows one box by its AO. If the issue persists go to step 2.
- Clear the address book entries in the device that has the AO with both boxes (this is usually the UNC) and reboot the device.
- When the station comes back up carefully re-enter the Address book data and then check each AO to make sure both have two boxes. Typically this will resolve the issue, but until both AO's have boxes on both sides the issue is not resolved.
It may be necessary to clear and redefine the address book a second time or clear and redefine the address books in both devices to pass this test. Once the AO test is successful the Master / Slave scheduling will link and function as expected.
Ensure that ports 80 and 3011 are added as exceptions in the firewall application. Refer to Which antivirus software is compatible with Niagara R2 and G3? for details.