Issue
How to setup a Pelco DVR in Security Expert.
Product Line
Pelco, EcoStruxure Security Expert
Environment
- Security Expert
- Pelco DVR
- Endura DVR
Cause
Unsure what the Service Port and DVR port settings are and how to configure the rest of the settings for a DVR object in Security Expert.
Resolution
When configuring your DVR in Security Expert you use the Custom DVR Type, all the preset DVR types are for legacy systems. In earlier builds of the software Video Services were integrated directly, these are now being run as separate services.
- When you install the Video Service you specify a Service Port – it can be any unused port whatsoever, the default is usually fine – take note of this port number. Once installed you need to manually start the service.
- In Security Expert you set the DVR Type to "Custom", set the IP Address, and then the Service Port same as above – the DVR Port is configured from the DVR software/Web interface, usually their documentation will cover this. Then just add the Username and Password used to login to the DVR.
(See image below which shows the relevant settings highlighted in red.) - If you make any changes to the DVR settings you will need to restart the Video Service and the Security Expert DVR B service for them to take effect.
In Security Expert, add DVR objects by going to Monitoring > Setup > DVRS
- IP Address: IP of the DVR.
- DVR Port: Defined in the DVR software/Web interface. The default for the more recent Pelco DVRs is 60001, and the older models is 18772 (consult your specific DVR documentation for details).
- Service Port: Port configured during installation of Pelco Video Service. (This field appears when DVR Type is changed to Custom)
- DVR Type: Select Custom.
- Username / Password: Credentials for the DVR.
Also refer to Support for Pelco VideoXpert Integration and Pelco's partners website for up to date information on Pelco integrations with Security Expert.