Issue
How to safely de-commission an Access Controller with configured Doors and Personnel.
Environment
Continuum Cyberstation
Access Controllers
Cause
In the past, when deleting Access controllers from a live site, problems have been encountered with controllers that had pending Personnel distributions.
Resolution
As long as there are no pending distributions to the controller, deleting the controller from Continuum should be problem free.
The problem with distributions begins when a controller is still defined in the database but is not online. Any changes to personnel in this offline controller will be "buffered" until the controller comes back online. Deleting the controller device object out of the database stops these distributions from being attempted in the first place.
The most comprehensive method of removing personnel from a controller during de-commissioning is to do the following:
- For the Personnel, remove access to the Areas that the controller supplies access too. These changes will then distribute down to the controller and remove these personnel from it.
- Once the distributions are complete, remove the Areas from the door objects in the controller, if not using profiles. (When using profiles in the Personnel Manager do not remove Areas, this can potentially cause database issues)
-
Then to complete the de-commissioning, delete the controllers Device object from the Continuum database.