Issue
When running a listview on the alarm log it appears there are instances where the alarm was acknowledged before the timestamp. How can this happen?
Product Line
Andover Continuum
Environment
Time Sync
Cause
This issue can occur if the Continuum system is not properly time synchronized.
In order to properly sync the system time, it's helpful to understand where the various alarm time attributes are set:
- TimeStamp comes from the controller's time
- TimeofLog comes from the SQL Server's time
- TimeofAck comes from the Acknowledging CyberStation's time
Resolution
Make sure all the components of the system are properly time synchronized.
Methods of synchronizing server and workstation times may vary based on the workstation operating system and if your network is using active directory. Refer to the network administrator to verify if time sync is being done, and under what conditions (logon only and/or a schedule) and how often.
If Continuum is on an isolated network refer to http://support.microsoft.com and search on network time synchronization to learn about the different options for the particular network configuration.
As for the workstation-to-controller time sync, Time sync controllers to workstations includes a program to which will sync the workstation time to the controllers.
TimeOfLog and TimeStamp columns in an Alarm or AccessEvent listview are different covers a couple of conditions where the TimeStamp and TimeofLog may vary considerably.
Periodically, verify that all the components are in sync.