Issue
By design, the Continuum system cannot delete personnel objects until all the distributed copies can be first removed from the controller(s).
In some cases the distributed copies cannot be removed from the controllers, such as when a controller is permanently offline or has been deleted.
Product Line
Andover Continuum
Environment
CyberStation
Cause
Communication failure between CyberStation and controllers.
Resolution
Starting in CyberStation version 1.94 a new feature has been added that allows the user to force a delete of personnel objects even if the distributed copies cannot be removed.
In CyberStation 'Delay Distribution' dialog, a new button has been added; the button is only enabled when CyberStation is in offline edit mode.
- Make a backup of the Continuum database as a precaution.
- Close ALL CyberStation workstations.
- Put CyberStation in Offline edit mode to enable the 'Clean up failed personnel delete distribution' button
- Click on the button, the system will provide the following warning
- Click OK to force all personnel deletions that are pending or have failed distribution to complete; any distributed copies in the controllers will be left orphaned.
- If offline controller returns online orphan distributed personnel records in controller can be removed by one of the following methods:
- Cool start the controller. (For controllers that support access control and backup to flash such as the CX9680, ACX5720, ACX5740 . Note that personnel objects ARE NOT saved to flash memory, the controller requests a personnel distribution from CyberStation on cool start). See Restart modes of the second generation Infinity controllers for more information on cool start.
- Reload the controller from the CyberStation, this will perform a cold start and re-send all objects to the controller followed by a personnel distribution.