Issue
When attempting to run LonMaker, the following errors may occur in succession:
- Could not listen on poet/tcp: The address specified is already in use (Error -2532)
- Database error:
(Subsystem: LNS, #25) [DB #-2506]
The global database is not open.
(Subsystem: LNS, #64)
Additional errors that may be caused by the same underlying issue:
- Problem connecting with the database server process:
(Subsystem: LNS, #36) [DB#-2523] - Error opening LCA Global database
Product Line
EcoStruxure Building Operation, Satchwell BAS & Sigma, TAC IA Series, TAC VistaEnvironment
- LonMaker for Windows 3.1 and 3.2
- Sentinel Protection Installer 7.6.1
Cause
The issue is typically caused by a conflict between the Sentinel Protection Server and the POET Server, as both attempt to use the same port(s).
- Sentinel Protection Installer 7.6.1 installs the Sentinel Protection Server, which manages Sentinel SuperPro and UltraPro keys used with Satchwell Sigma and other products
- This service is not required for the dongle driver to function and can interfere with LonMaker’s operation.
Refer to:
Error: LNS #25 lcaErrDatabase for more technical details.
Resolution
To resolve the issue:
-
Stop the Sentinel Protection Server:
- Open the Windows Services console:
- Press
Windows + R, typeservices.msc, and press Enter.
- Press
- Locate Sentinel Protection Server.
- Right-click and select Stop.
- Open the Windows Services console:
-
(Optional): Disable the service if not needed:
- Right-click > Properties > Set Startup type to Disabled.
✅ This will allow POET Server to operate without port conflicts.