Issue
Changing the Module ID after physically replacing a modules gives error "Incorrect response (or no response) from IO module"
Product Line
Andover Continuum
Environment
- CyberStation
- CX9900
- CX9940
- CX9680
- IOU Module
Cause
Controller's OMS database is out of sync with SQL database.
Resolution
To synchronize the OMS database with the SQL database:-
- Put CyberStation in offline edit mode.
- Edit the IOU Module object and enter the new Module ID.
- Save the object
- Return CyberStation to online edit mode.
- Perform a Send to controller, reloading the controller will sync the OMS db in the controller with the SQL database.
Note the following:
- Make sure to use the option to reload attached objects but not attached controllers
- If IOUs go offline when sending to controller after doing this, manually get IOUs online, perform a send to database and send to controller.
- If a number of IOUs were replaced this process may need to be repeated several times until the send to controller works with no errors.