Issue
Error when trying to register plug-ins within an LNS environment. Two known examples:
Plug-in 'TACOSSysPin.Document' launch failure.
Unknown error 0X8007002
Plug-in 'TACOSSysPin.Document' launch failure.
Exception occurred
Product Line
TAC Vista
Environment
- LonMaker 3.X
- TAC Vista System Plug-in
Cause
There are two types of credits: Product specific credits like LonMaker or NL credits and then there are LNS credits. LonMaker/NL credits are used by LonMaker/NL220 to commission devices. LNS credits are not consumed by commissioning devices in LonMaker, but are consumed when commissioning devices in NL220. LNS credits are used by other LNS applications – like the TAC Vista System Plug-in. While LNS credits may not be consumed by LonMaker, they must be present in order for the plug-ins to launch. Backing up, sharing, and restoring LNS databases can sometimes corrupt these LNS credits, which then prohibits you from launching any LNS plug-ins. For more information regarding NL220 and LNS credits see Ordering more LNS credits.
Resolution
Echelon released a Licensing Update in January of 2006 to improve the reliability of the Echelon licensing software, which was compromised due to newer security and self-protection features of Windows. This will not fix your already corrupted license files; however, this will help prevent the license from becoming corrupted in the future. It is highly recommended that this update be installed on all applicable products.
- If you do not already have the LNS Licensing Update 2006 software (LnsLicensingUpdate2006.exe), download it from http://www.echelon.com/support/downloads/detail.asp?partNum=153-0155-01A. If you do not already have one, you will need to create a user account with Echelon. It is free.
- Shut down all LNS applications, including LNS enabled Windows services. LNS enabled Windows services are LNS applications that are being run under the Windows Service Manager as background processes. Examples from Echelon include the LNS Server application and the LNS DDE Server. Third party examples are typically HMI drivers for HMI workstation software products.
- Log on with Administrator privilege.
- For version 3 LNS Server installations that are not already at LNS version 3.08 or higher, LNS 3 Service Pack 8 or higher must be installed before applying this update. Service packs are available from www.echelon.com/downloads.
- Run LnsLicensingUpdate2006.exe.
- Reboot if requested by the installer.
To resolve the issue of corrupted LNS credits:
- Run the LNS Server License Wizard by navigating to Start > Programs > Echelon LNS Utilities > LNS Server License Wizard. It can also be found at C:\LonWorks\bin\LnsLic.exe.
- If the Max Credits, Credits Available, Max Deficits, Deficits Remaining, or Days Remaining are displaying zero values, then your LNS credits have become corrupted.
- To order free LNS replacement credits, hit Next.
- Hit Copy to Clipboard and paste into a blank email.
- After entering your specific contact information, you will want to check the "No Charge" box and the "Replacement Use" box.
- Before you send the form via fax or email, you also need to provide evidence that your LNS credits have been corrupted. Select Start > Run > and type "cmd" to reach a command prompt. This command will check the status of the LNS credits:
checklic nsseng.exe
An example of a working license is show below: - The output of this command should either be printed and sent with the fax or included in the email.
- Send the completed form to credits@echelon.com or print the forms and fax them to 1-408-790-3833. Note: If you are accustomed to ordering credits through another entity, do not send them this form. Only Echelon can issue replacement LNS credits.
- Echelon will reply with an application key that can be entered in this same window. When the LNS credits are restored, the System Plug-in should launch.