Issue
Get error message "OPC communication error" when trying to view Vista OPC server objects in OPC tool.
Product Line
TAC Vista
Environment
- TAC Vista 5.1.X
- TAC Vista OPC server 1.6.1
Cause
Incorrect version installed or DCOM settings.
Resolution
- Confirm which version of Vista OPC server is installed.
- Go to control panel\add remove programs and double check that it is version 1.6.1. that is installed.
- Confirm that OPC server setup account settings aren't being saved.
- Go to Start\Programs\Schneider Electric\TAC Vista OPC server\Tac OPC Server setup.
- Under Login to TAC Vista server, change to Login using the following TAC Vista account and fill in the appropriate user details.
- Click OK and close the dialogue.
- Re-open the TAC OPC server setup dialogue and see if the account details added in b are still there. If so then there is probably a problem with DCOM settings (see TAC Vista OPC Server Technical Manual). If the option Login using the windows account which is running the TAC Vista OPC server is re-selected TAC Vista OPC server 1.6.0 must first be installed according to OPC server for TAC Vista will not keep the login settings in the TAC Vista OPC Server setup.