Issue
- Unable to connect to a system that is using Server/Client Configuration. After promoting a stand alone PC to a remote client and clicking on the connect button, an error "No Entries in Database" comes up and the user cannot connect to any of the controllers on the system.
- After a restart of PC and an attempt to connect to the I/NET System, an error "No entries in database" is seen.
Product Line
TAC INET
Environment
- I/NET Seven
- Windows 7, Windows XP, Windows Vista, Windows 10
Cause
Some of the possible causes :
After promoting a stand alone PC to a remote client the Reference Host information of both the server and the client must be updated with the IP addresses of each other.
Bad communication or bad controller that is connecting the C-LAN to the Xenta 527
In some instances when running the I/NET IO Server as a service and after a restart of the PC hardware running a Windows 10 Operating System, it is has been seen to produce this "No entries in database" error. At this stage the reason is currently unknown but the connection to the Xenta 527 is not made and the IO Server service needs to be restarted.
Resolution
- Open I/O Server
- Hit the Modify button
- In the Reference Host Column, add the IP address of the server
- Repeat steps 1-3 on the server, adding the IP address of the remote client.
Note: Should the Xenta 527 still not communicate to the controller:
- Verify that the C-LAN wire is connected properly
- There is communications between the controllers and the Xenta 527
- If not, unplug the C-Lan connector, from all the controllers and bring them online one at a time to determine which one could be bad.
- Replace possible bad controller and the system should come online again.
To correct the issue after a PC hardware restart, two options are available
- Restart the I/O Server service
- Change the run mode of the I/O Server to an application. See Running I/NET Seven as a service on Windows for further information on options on how to achieve this.