Issue
The binding between an Enterprise Server and Automation Server or between two Automation Servers shows Unresolved
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Enterprise Server
- Building Operation Automation Server
- Binding Diagnostics
Cause
The communication between the two servers is incorrectly configured, blocked by software such as firewalls or antivirus or another application is using the port.
Resolution
For Firewall Issues:
Ensure the Windows firewall on the Enterprise Server PC is set up correctly, for example follow Creating Windows Firewall rules to allow Building Operation to communicate on the TCP port to set up inbound and outbound rules.
Alternatively configure the Windows firewall using the Firewall Config tool on all PC's having EcoStruxure software installed.
Problems with firewall settings can arise if the Enterprise Server PC is removed during the commissioning process and the firewall settings swap between Private Networks and Public Networks.
For example
- All the Automation Servers may appear online, but the "Unresolved" bindings issue may be seen.
- Automation Servers cannot be restored via the Enterprise Server
If a suitable option temporarily disable the firewall to see if it fixes the issue.
For 1.4 or 1.5 Servers with a name containing the "&" symbol:
Ask Product Support for Hotfix R1.4.1.16201 (or later version) for version 1.4 and R1.5.0.1601 (or later version) for version 1.5.
For other Causes:
Follow these troubleshooting steps in order until the issue has been resolved.
- Check that the ES IP address is the same as the PC IP address. If they do not match, follow How to set the Enterprise Server IP address to change the ES IP.
- All ports must be open between the ES and AS, for port numbers search "Network Ports" in the Information Technology System Planning Guide.
- If the address of the ES is a domain name, try using the IP address instead.
- If there are more than one network adaptor on the ES can, for example, take the address of a wireless adaptor, VMware virtual adaptor or VirtualBox adaptor. The ES should be using the NIC adaptor, either follow the link in item 1 or disable the other network adaptors.
- Right click on the ES and select Advanced > Repair Server Communication. This should update the Communication tables of the servers.
- Detach the automation servers from the ES and then add the automation servers back. Follow Unable to add an Automation Server underneath an Enterprise Server.
- Select each server and click on the Communication Tab. If communication is valid, it should list the details of every other server.
- Try to disable any network monitor function of anti-virus software on the computer.
- If a Schneider laptop is used, right click the Trellix software in the system tray and Enable Firewall Timed Groups.
- Although not a supported architecture if a user installs the Enterprise Central and Enterprise Server on the same PC with default settings the ports will conflict. Either remove the unsupported Enterprise Central or if for testing stop the service and set appropriate usable ports.