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ETL Task not working when running as a service

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ETL Task not working when running as a service

Picard Product_Support
‎2018-09-11 08:15 AM

Last Updated: Admiral David_Kendrick Admiral 3 weeks ago

Issue

When creating an ETL task the "Run Once" option works, but when configured to run as a service, it doesn't work and an error occurs in the error log:

2015-05-22 17:13:59,069 ERROR ETLEngine (TaskName) - Thread ID (119) - Power Monitoring Expert Load Task: Task Power Monitoring Expert Load Task failed
System.ApplicationException: Failed to populate the MetaDataSet. ---> System.Data.SqlClient.SqlException: Cannot open database "ION_Data" requested by the login. The login failed.
Login failed for user 'NT AUTHORITY\SYSTEM'.

Product Line

EcoStruxure Building Operation, Other

Environment

  • Power Monitoring Expert
  • Energy Expert (formerly Power Manager)
  • ETL Tool

Cause

  • When testing the ETL task using "Run Once", the Windows account currently logged in, will be used to access the SQL database. However, when the same Task is then configured to run as a service, the account configured on that Service will be used to access the SQL database instead.  By default that account is the built-in account 'NT AUTHORITY\SYSTEM'.
     
  • The Position values for all of the mapped trend logs are set to an unreasonable timestamp. The timestamp is either very old or a date the preceeds the oldest values in the database. 

Resolution

Changing the Windows system account for the ETL service

  • Either give the system account access to the database, or change the account used to run the service.

Correct/Adjust the timestamp values in Positions tab of ETL

  • The timestamps can be changed all at once by setting the Initial value field at the top of the "Positions" window in the ETL tool. 
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