Issue
Unable to back up the Automation Server
Unable to retrieve a working backup from an Automation Server
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Automation Server
- Building Operation Automation Server Premium
- Building Operation Enterprise Server
- Building Operation Enterprise Central
Cause
Corrupt configuration.db
Network environment issues
Power failure
Resolution
Database Corruption
When the server backup process is initiated, the server tests the integrity of the configuration.db. If the database does not pass the integrity test, the backup process is terminated, and no resulting backup is produced.
In this case, an older backup will need to be used. The backup should be bench tested for integrity before restoring to the production server.
Network Environment
In some cases, the AS may produce a valid backup file, but when the backup is saved off of the server the file size is unusually small. This can happen when network issues interfere with the backup save to disk process.
In such cases, Automation Server backups taken from the Enterprise server will usually be damaged as well.
You can work around this problem by connecting a Workstation laptop PC directly to the AS with an ethernet cable, thus eliminating the network from the process.
Backups can also be retrieved in this way using most versions of Device Administrator.
Power Failure
The power fails while the EcoStruxure BMS server is backing up and the system displays a “Failed backup” message in the Event view. The solution is to initiate a new backup when the power resumes and the EcoStruxure BMS server goes back online. Power Failure Occurs During Backup