Issue
Unable to connect Enterprise Server or Enterprise Central to the Building Advisor Cloud Portal
Product Line
EcoStruxure Building Advisor, EcoStruxure Building Operation
Environment
- Building Operation Building Advisor EBO Health Module
- Building Operation Enterprise Server
- Building Operation Enterprise Central
Cause
There are some Operating System Requirements that need to be checked and enforced.
Resolution
Incompatible versions lead to missing trust certificates that could hinder the connection to Azure cloud services.
The table below provides a compatibility matrix of EBO versions and supported Windows OS that is necessary for the cloud-connectivity to work reliably.
Enterprise Server Software Requirements | |||||||
EBO Version | v2.0 | v2.1 | v3.0 | v3.1 | v3.2 | v3.3 | v4.0 |
Microsoft Windows 7 (64-bit) | Yes | Yes | Yes | Yes | No | No | No |
Microsoft Windows 8.1 (64-bit) | Yes | Yes | Yes | No | No | No | No |
Microsoft Windows 10(64-bit) | Yes | Yes | Yes | Yes | Yes | Yes | Yes |
Microsoft Windows Server 2008 R2 (64-bit) | Yes | Yes | Yes | No | No | No | No |
Microsoft Windows Server 2012 (64-bit) | Yes | Yes | Yes | No | No | No | No |
Microsoft Windows Server 2012 R2 (64-bit) | Yes | Yes | Yes | Yes | Yes | Yes | Yes |
Microsoft Windows Server 2016 | Yes | Yes | Yes | Yes | Yes | Yes | Yes |
Microsoft Windows Server 2019 | Yes | Yes | Yes | Yes | |||
Microsoft .NET Framework 4.5 or 4.6 | Yes | Yes | |||||
Microsoft .NET Framework 4.7.2 or later | Yes | Yes | Yes | Yes | Yes |
The SmartX servers also require TLS1.2 to be enabled to communicate with the BA cloud properly.
- Automation servers (AS-P/AS-B) have TLS1.2 enabled by default.
- Check that the Windows OS running Enterprise Server has TLS1.2 is enabled by following the steps in this link: How to Check if TLS1.2 is Enabled