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Dump file imports fail, have errors, or have blank programs with no code.

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Dump file imports fail, have errors, or have blank programs with no code.

Picard Product_Support
‎2018-09-10 12:59 PM

Issue

Dump file imports fail, have errors, or have blank programs with no code.

Environment

Continuum Cyberstation

Cause

Large dump file imports (such as an entire site database) can have problems where the import gets out of sync and fail.

Making any changes to the dump file with an editor such as Word, Wordpad, or Edit applications. These text editors cause problems formatting, the bytecode of InfinityPrograms do not have a carriage return and the editor can end up pushing all the lines of code up onto one line. This can't be imported properly due to the line now being greater than the maximum line size.

Resolution

The following recommendations should be considered when importing dump files:

  1. Usually breaking these large imports up into smaller chunks (each controller) results in a smoother import and more success.
  2. Use a true ASCII text editor such as Notepad++ to make changes to dump files. Always save changes to a new filename so the original is left untouched. 
  3. You may also need to remov the Workstation Folder and Workstation, re-initialized the Continuum Workstation and then retry the import.
     
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