Issue
Deleting logs from External Log Storage takes a very long time.
Workstation becomes unresponsive when deleting trends from External Log Storage.
Product Line
EcoStruxure Building Operation
Environment
Building Operation Timescale Database
Cause
The deletion process can take a long time on large PostgrSQL databases, sometimes as much as an hour.
Workstation must complete the deletion process before it becomes available for other tasks.
When logged into Enterprise Server to delete a trend that was hosted by a child server (Automation Server), Workstation tags the log for deletion. The AS that held the original log, will survey the trend_meta table every hour to check for pending flags, and will then delete logs that are flagged. This can cause the deletion to be delayed by as much as an hour.
Resolution
The following method should be used when deleting trends from External Log Storage:
- The trend must no longer exist in EBO.
- Log on locally to the server that hosted the associated trend. Then deleted the trend from the System\External Log Storage folder.
- Indexing the trend_data table can improve the speed of deletion dramatically in large PostgreSQL databases (1 TB or larger).