Issue
Creating a test database for troubleshooting
Product Line
Andover Continuum
Environment
Continuum test database
Cause
There are times when troubleshooting an issue when creating a test database is useful.
Resolution
Open up Database Initialization
- Select Server if you have a LAN install with a Full SQL license or Stand Alone if you are using MSDE or SQL Express
- Click on the Create New database radio button (bottom right) which opens up the needed fields
- Change the Database name from Continuumdb (default) to Testdb
- Under Device Information, Change Database from ContinuumDev to TestDev
- Under Device Information, Change Database from ContinuumLog to TestLog
- Ensure the path is correct for DB File location
- Enter in the sa password
- Click Continue (This creates 2 files TestDev.mdb and TestLog.ldb in the DB File folder)
Go to Database Initialization again
- Select Workstation
- Leave the info on the workstation tab exactly as they are
- Click on the Database tab
- Change the Database Name from Continuumdb to Testdb
- Click Ok (This will resolve the workstation to the new test db)
Start Continuum and perform the test and see if the issue still happens on this clean db.
- Once the test is completed, delete the Testdb database from Enterprise Manager or use osql
- Go to Database Initialization again
- Select Workstation
- Leave the info on the workstation tab exactly as they are
- Click on the Database tab
- Change the Database Name from Testdb to Continuumdb
- Click Ok (This will resolve the workstation back to the Continuumdb)