Issue
When adding License Entitlements via Device Administrator using the online method. After clicking activate, a "Communication failed" message is displayed:
Could not establish contact with License Server using SmartX Server
Followed by a "License Operation Failed" message:
Add entitlement failed. License Server is offline. Error code: 41 Error message: CURL error:
Product Line
EcoStruxure Building Operation
Environment
- Device Administrator
- Building Operation Automation Server Premium
- Building Operation Automation Server Bundled
Cause
When activating a SmartX Server license online, the SmartX server will try to connect to the license activation server to activate the license. If it cannot resolve the license activation server site name and connect, it will show up as offline.
Resolution
Make sure that the SmartX Server DNS is properly configured in the AS-P.
- In Device Administrator select the Ethernet 1 Configuration tab.
- Check the Primary, Secondary, and Tertiary DNS settings If unsure of the correct DNS address, enter the Google DNS address of 8.8.8.8 or 8.8.4.4.
The example below shows a local router address as the Primary DNS and Google DNS as the Secondary and Tertiary DNS.
To confirm that the SmartX Server can resolve the license activation server address
- Open a Console session on the SmartX Server in Device Administrator.
- Enter the command: ping schneider-electric.flexnetoperations.com
- If the DNS is correctly set in the SmartX Server, the result should look similar to that shown below:
Note:
- Ensure that the ASP is fully connected to the Internet in order to perform Online Embedded License Activation.
- You need to be connected to the Automation Server using IP (Not via USB) to activate the embedded license.