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Checklist for maintaining or servicing a typical Continuum installation

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Checklist for maintaining or servicing a typical Continuum installation

Picard Product_Support
‎2018-09-11 01:20 AM

Last Updated: Administrator CraigEl Administrator ‎2022-08-08 09:13 PM

Issue

Checklist to be used as a basis for Maintenance visits.

Product Line

Andover Continuum

Environment

  • Continuum Hardware
  • Continuum Software

Cause

Having a checklist available for routine maintenance will help with service calls to ensure Continuum sites continue to run smoothly over the life of the installation.

Resolution

There is no official maintenance checklist but some of the things you might want to consider checking on a regular basis are the items below.

  1. Continuum Analyzer
    Run the tests which check the database for known issues and provides a results file. See How to run Continuum Analyzer and get a report.
     
  2. Review Windows Event Logs
    Check the Application and System Event logs for Continuum or SQL related errors. See Viewing, Saving, Sharing Windows Event Logs for Troubleshooting Purposes.
     
  3. Check the size of the ContinuumDB
    The Database can't be more than 2GB in MSDE, 4GB in SQL Express, and the size of available space on the drive if using full SQL Server. Continuum will always run better when the database is kept trim, as the database size grows, Continuum transactions may start to slow down. If general system slowness is observed then check the database size and SQL Server resources first.
     
  4. Truncate/trim event tables in ContinuumDB
    Especially the ExtendedLog table which can grow very rapidly if not kept in check. See Set up a Continuum system to do automatic log truncation to save database space.
     
  5. Check that the Continuum Workstation is patched and up to date
    Periodically service packs and hotfixes are released for different versions of Continuum to resolve identified issues. Consult The Exchange Download Center for the current updates.
    Service Packs | Hotfixes
     
  6. Check that Controller Firmware is up to date
    Check that the Controller firmware versions are supported for your version of Continuum and that they are up to date. Same as service packs for Continuum, new firmware builds are released as issues are identified and resolved. You can find supported firmware for each version of Continuum in the Compatibility Matrix. See Software and Firmware compatibility matrix for older versions of I/NET, Vista, Andover Continuum, Sa....
    And new firmware updates are available on Exchange Extranet.
     
  7. Check battery charges
    On controllers that have them, check that the battery for holding up the active RAM still has a charge.
    How to check -> Battery life in Andover Continuum controllers that have onboard batteries
    Replacement batteries -> Replacement batteries for the various Continuum controllers
     
  8. Run the Continuum Errors listviews to see if there are any recurring errors that may need to be investigated.
     
  9. Most Importantly - Backup the ContinuumDB before leaving site!
    Backup and restore instructions for a single-user system are below but these also apply to full SQL Server using Management Studio. Steps 1 and 2 in the article below apply to backing up a ContinuumDB. See Move / Backup / Restore a database on a Single User SQL2005 Express system.
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