Issue
Need to change from the Small Number Format (Card Number) to the Large Number Format (Facility Code + Card Number).
Requirement for Security Expert Transitions with I/NET Hardware.
Badging card on SCU1284 Reader using Security Expert, the reader event displays "Format error RD xx Port x Error Number of Bits"
Product Line
TAC INET, EcoStruxure Security Expert
Environment
- I/NET Seven
- Security Expert Transitions
Cause
The I/NET system is limited to a maximum number of access cards, 32,000 per Tenant. If a larger number is required, then I/NET must be configured to use large card numbers.
The Large card number format described in the Resolution MUST be completed before transitioning from I/NET to Security Expert and utilizing the I/NET SCU hardware as detailed in the Transition Guide Security Expert - INet Access Control to Security Expert - Reference Guide.
Resolution
To convert I/NET to use the Large Card Number support, the following steps must be performed:
Conversion of Card Numbers (small) to Large Numbers
- Sort the Individuals list according to the Individual Number. Look in the Individuals Editor “Options” function to set this up.
- Look at the tenant editor to determine the Tenant Code/ Facility code of the cards.
From this, use the circled items the Tenant Code (Facility Code) and the First Individual Number as the lowest possible card number in the next step. - Verify in the door editor that the cards in this system are in a known Weigand bit format. In this case, we are using 26-bit.
Attached are various Excel spreadsheets that can determine the Decimal number of the first card in the system (e.g., Card #970 Facility code 199) is the Decimal number 13042634, using a 26-bit Weigand Excel spreadsheet. This number will become the Source number in the Key/Card Translation table.
These include - Create a Key/Card Translation table similar to that shown below in the I/NET Seven Access Control editor. This table will be removed after running the provided SQL Script.
The Key/Card Translation must contain:
- Source - Decimal number calculated in Step 3 above (13042634)
- Target - First Individual number shown in the Tenant (970)
- Count - Number of Individuals as shown in the Tenant (10000)
- Tenant - Tenant number this translation refers to (1)
If there are multiple Tenants, then this process MUST be repeated for each Tenant
- Shut down I/NET completely and run the attached SQL Script. Then once the script runs then, restart I/NET and look in the Individual Parameters editor, as shown below.
- Start I/NET and delete the Key/Card Translation table create above.
- Open the Individual Parameters and verify a Hex number and the decimal number matching that from the Excel spreadsheet (Step 3) is seen in the Individual Editor Card section.
NOTE: There may be multiple card entries here; the Last entry shown is that entered by the SQL Script. It will depend on whether an existing Card entry was entered for the Individuals before running the SQL Script.
- To have large numbers working on a site
- DipSw #7 has to be turned ON for the 7910/7920 DPUs.
- For the SCU1284 in the door editor, at the top center of that editor, there is a check box, "Card Translation," which has to be enabled for large numbers to work in the SCUs.
- An SLI “SAV” should then be done because that is where the Card numbers and Door settings are stored.
- Then perform an SLI restore.
- Followed by a DPU restore to all of the door controllers.
NOTE: Steps 6d. and 6e. are NOT required when performing the transition to Security Expert as this information will be performed by the SP-C.