Issue
- Opening and running a Seven Report that uses the Calendar to define the date range feature for data after entering the values, and nothing happens. It does not pull up any data.
- Business Objects error is seen in the Calendar picker.
Product Line
TAC INET
Environment
- I/NET Seven revision 2.31 and higher.
- Seven Reports (Crystal Reports)
Cause
Crystal Reports has not been set up correctly on the host PC. An additional file has to be installed to handle scripts in Seven Reports. This file can be found under >Support>Sevenreport/CR_XI/PostCRSetup on the INET CD. A read me is also located there to assist with the installation procedure:
Resolution
To resolve this issue, the following steps need to be implemented:
- Close I/NET and I/O Server
- Open up Windows Explorer and select the original CD
- Open up the Support Folder and expand it
- Select the CR-XI folder and run the SetupCrystalReportsXI.exe
- Once completed, go back into the folder again and run the Post CRSetup.exe
- Once this is completed, restart I/Net and I/O Servers again
- Open up Seven Reports again and run the associated report