Issue
Browsing between different records in the Security Expert Client is slow. It takes a longer than normal amount of time to see records update.
Product Line
EcoStruxure Security Expert
Environment
Security Expert Client
Cause
There are a large number of unacknowledged alarms being stored in the SecurityExpertEvents database. When the Security Expert Client starts up it will process all of these unacknowledged alarms which can impact browsing the database.
Resolution
To resolve the immediate problem:
1. Reduce the size of the SecurityExpertEvents database by reducing the overall number of events that will be stored. Setting up automatic event purging and backup helps keep this in check.
- Under Global | Global Settings | General change the Purge Events older than from the default setting of "Never" to another value from the drop down menu.
- To backup these events before being purged, ensure the Generate Differential Events Backup option is checked. This is the default setting.
2. If there are more alarms to be acknowledged than can be done manually then contact Product Support mentioning this Knowledge Base Article. Remote access to the site and SQL Server will be required.
To minimize this from happening again:
1. Reduce the amount of events that are setup as alarms.
- Remove any alarms that are setup for All Events and review any configured alarms to ensure those events are required to be generating alarms.
- Double check all Inputs and Trouble Inputs to see if they have the Log to Event Buffer option enabled. Not all inputs will require this for normal operation and in some cases having this enabled can result in a large number of unwanted events being logged. This, in addition to an alarm setup to monitor the All Events event filter, is a recipe for disaster resulting in a large number of alarms being generated in a short amount of time.
2. Ensure that a large number of unacknowledged alarms are not allowed to build up over time.
- Alarms are not able to automatically acknowledged and will stay in the active alarms list until an operator acknowledges them.
- Operators need to acknowledge alarms on a regular basis. Note that it is possible to batch acknowledge blocks of alarms at one time in the Security Expert Client by doing a multiple selection then right-click acknowledge alarm.
Note:
If your system has already built up a large number of unacknowledged alarms and you want to quickly acknowledge them all at once to get back to a manageable starting point, then please raise a Support Case with your local Customer Care Centre and Product Support can assist in doing this with a 'one time' SQL Query direct to the Security Expert Database.