Issue
- Receive error "Property value out of range" when creating a BACnet interface on the Enterprise Server
- Following problems after upgrading SmartStruxure servers to 1.5:
- Attaching an Automation Server to or detaching it from an Enterprise Server will fail with “Property value out of range” error.
- Changes to the ~/System/Interface Manager/BACnet fail to be propagated lead-shadow functions through to the child servers.
- Automation Server controllers dropping offline following an upgrade to 1.5 (BACnet command priority related also may see numerous "Changeset Rollback errors")
Product Line
StruxureWare Building Operation 1.1, 1.2, 1.4, 1.5 and above
Environment
- Enterprise Server (ES) BACnet IP Interface
- Windows XP, Windows 7 and Windows Server 2008 R2
Cause
Their may be various items that generate this error, checking the Enterprise Server (ES) system log in the Software Administrator may assist in pin pointing the error. If you see an error that ends with ~/BACnet Interface/IP Network, then this error is generated when their is no valid IP Network.
For SmartStruxure 1.5 or above or planning to upgrade from 1.4 to 1.5 (and above)
This issue only occurs if a BACnet interface is used and the site has changed the BACnet "Default Priority Level" from the default value of 16, to 8 or a smaller numeric value in the Automation Server while running in V1.4. The "Property value out of range" message relates to the new Force priority level in 1.5 and the Default priority level in 1.4.1 being mismatched.
Resolution
The ES must be connected to an IP network. To resolve this error follow these steps:
- Close all Workstations (if running)
- Connect the Enterprise Server to a valid IP network (with a valid IP address).
- Stop and Restart the Enterprise Server service through the Software Administrator application.
- This should now allow the BACnet Interface to be created successfully
For SmartStruxure 1.5 or above or planning to upgrade from 1.4 to 1.5 (and above)
Please refer to TPA-SBO-14-0005.00
Before upgrading to 1.5 make sure the "Default Priority Level" within the Automation Server is set to 9 or higher.
If the system has been upgraded with the incorrect values, then:
- If the site uses single servers, or the ES/AS communication still operates correctly, then this can be corrected by changing the setting in both the AS and the ES to a value of 9 or higher.
- If after upgrading a multi server configuration and the AS does not stay online, then a Hotfix can be used fix the problem using the following steps:
- Apply the hot fix #1.5.0.4301; available from Product Support Services
- Fix the multi-server (by detaching/re-attaching the servers)
- Correct the two properties (AS and ES).
WARNING: It is essential for any BACnet system at 1.5 or later that the "Default Priority Level" must have a larger numeric value than the "Force Priority Level, otherwise some BACnet functions may not behave as expected.
Note: This also applies even if the hot fix has been installed.
The effects of not setting the Default above the Force Priority level are:
- If Force Priority Level is equal to the Default Priority Level:
Changing the Value of a BACnet value or a BACnet output object will cause the Value to appear Forced. This applies to the BACnet objects in both SmartStruxure servers and those in 3rd party BACnet devices.
- If Force Priority Level has a larger numeric value than the Default Priority Level:
Changing the Value of objects mentioned above will cause the Priority Override icon overlay to be turned on next to the Value property in the WorkStation’s property grid.