Issue
Alarms show up in Active Alarm View but do not show up in any Alarms listviews and do not seem to be logging to the Database.
Environment
Continuum Cyberstation
Cause
- Enhanced alarm logging does not automatically log intrinsic alarms (Controller Offline alarms).
- Improper time synchronization between Workstations and field Controllers. Due to this, Listviews were not showing most recent entries as they were being sorted on "TimeStamp" (controller time of the alarm) attribute.
Resolution
-
Intrinsic alarms (controller offline alarms) need to have a Workstation setup in the delivery tab of the EventNotification (in the Templates folder). The Workstation needs to have the "Log" box ticked so this alarm to be logged in the database.
Normally when using enhanced alarm logging, ticking this box is not required as the enhanced alarm logging takes care of the logging. These intrinsic alarms in the Templates folder are the exceptions to that rule. -
Confirm the times on your controller and WS are configured properly and showing the same time.
- Add the TimeOfLog attribute to the AllAlarms listview and change so it sorts on this to see if your alarms have been logged but at a different time.
- If there are no new entries, then try removing the alarm links to your points (on the alarms tab) and then re-add them and save.
- Reload the controllers as well.