Issue
Reporting is a powerful tool that allows for advanced monitoring of a system. It also allows for individuals or departments to monitor the usage and patterns of access. Scheduling a report allows for the delivery of reported data at a reliable interval and allows for the meeting of process requirements.
*Important Note: This is a Hosted Feature Only
Product Line
EcoStruxure Access Expert
Environment
Access Expert Hosted V3
Cause
Scheduled Reports not included in Access Access Reports by default
Resolution
When adding a New Report, the Schedulable column indicates whether a report can be scheduled or not.
Scheduled Reporting
Each report can be generated at the moment desired or configured to run on a schedule.
*Note: Scheduled reports must be created by a user within the instance the report is to be run in.
To schedule a Report
- Open the desired report.
- Click the “Schedule Report” button.
- Name the scheduled report.
- Select the Scheduled Report Tab on the Bottom Left Corner
- Enable the Report
- Set the desired timing.
- Apply the appropriate filters.
- Click “Save”.
- The report will now run based on the set schedule.
Report Settings
The Report settings configure the name of the report, the duration that the report will run, and the recipients of the report.
- The Display Name is the name that will show within Access Expert for that report.
- The ‘Starting On’ and ‘Ending On’ dates are OPTIONAL fields that allow a report to be run for a given time frame. For example, if construction is occurring in a section of the building for 3 weeks, an access request report can be run on the readers going into that area for the 3 weeks construction is taking place.
- The “Enabled” checkbox turns the scheduled report on or off. By unchecking this box, the report is scheduled but never runs. This box is checked by default.
- The recipient list shows who will receive the report. By default, the user who creates the report will receive the report via email. Additional recipients can be added by selecting the “Add Recipient” button and typing the name of the additional recipient.
Setting the Timing
The timing of the report is set using the generation time and pattern.
Report Generation Time
The Report Generation Time is the time of the day that the report will run on. The time zone drop-down allows the time to be set into the local time. By setting the time on the drop-down to 8:30 AM and the time zone to Central Time, the report will start to run at 8:30 AM central time every time it runs.
Recurrence Pattern
The recurrence pattern sets the frequency the report will run on.
- Daily: This sets the report to be run every given number of days.
- Weekly: This option allows for the report to be run on specified days of the week. The report can be set to run weekly or every 2/5/etc. weeks. The example below shows the report configured to run every Monday, Wednesday, and Friday each week.
- Monthly: This option allows for the report to be set up to run every X months, i.e. every 3 months for a quarterly report, or monthly on a specific date. It is important to note that if a date is selected that does not occur in that month, the report will not run, i.e. the 31st. If a monthly report is desired for the end of the month, it is best practice to set the report to run on the 1st of the month.
Context Menu
To access the Context Menu, Right-Click the desired report as shown below.