Issue
Access Expert SEQ Log Installation Information
Product Line
EcoStruxure Access Expert
Environment
Access Expert Hosted V3
Cause
The SEQ Log is a valuable troubleshooting tool to be installed separately from Access Expert
Resolution
Overview
Access Expert utilizes a system logging application called SEQ which is used for troubleshooting and diagnostic purposes. While this service is not technically required to run any of the Feenics services, it provides valuable information when troubleshooting.
Downloading SEQ
The latest version can be downloaded at https://getseq.net/Download
Installing SEQ
Once the MSI is launched the wizard will prompt for installation as shown in the following Figures.
SEQ service installation dialog
Once the SEQ logs are installed, click 'Browse Seq' button to open the log in the default browser.
Bookmark or Favorite
It may be beneficial to set the SEQ logs as a bookmark for easy access.
The example below is from Chrome.
SEQ Settings
Click on the 'Settings' option at the top of the page to access and change the defaults.
Initially after clicking on Settings, the API keys page opens. Add an API key if required.
API Keys
Retention Policy
From the settings page, select 'Retention' from the left-hand side menu.
Once at the Retention page, click add and set the retention policy. The Access Expert/Feenics default is 21 days. This is adjustable to your needs, however, it is recommended to never go below 7 days.
Note: Seq will periodically delete events covered by the policy based on their timestamp. Disk space will be reclaimed by a background compaction process and may not be available immediately.
Default is ‘all events’
Example Seq Log
Note: Left Click once to expand an event and click it again to shrink it
Tips and Troubleshooting
- Ensure SEQ is installed on the PC where the Access Expert client is installed or it cannot ingest the Access Expert events.
- If a reinstall of SEQ is needed, manually deleting C:\ProgramData\Seq and subfolders is required after uninstalling SEQ from Windows Control Panel> Programs and Features.
The SEQ uninstall does not remove the folder, subfolders and files.
If the folder and files are not removed, the installation will fail. -
Before reinstalling SEQ, Grant the User that is running the installation full permissions to C:\ProgramData\Seq and subfolders if they do not have them.
-
Installing SEQ using Windows Power Shell can be useful since it gives some feedback if something isn't working. Running the MSI installer within Windows doesn't give any feedback.
Command syntax:
seq service install --listen=http://localhost:5341/ -u "YourPCName\admin" -p "YourAccountPassword"Note: The username must be specified as DOMAIN\user or MACHINE\user
PowerShell Install Example:
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SEQ Log documentation: