Issue
An error may pop up when using Bosch RPS configuration software indicating there is an issue with the hardware key. The Bosch Panel is offline in Access Expert
Product Line
EcoStruxure Access Expert
Environment
- Access Expert Hosted V3
- Bosch Panel using RPS (Remote Programming Software)
- SafeNet USB Driver
Cause
The USB hardware key may not be installed or the driver needs to be updated or repaired
Resolution
Note: This solution assumes that the Bosch panel has been online in Access Expert before.
While working with a Bosch panel to integrate with Access Expert, the RPS software is used to configure the Bosch panel. An error may pop up indicating there is an issue with the USB security dongle that is inserted into the PC to connect to the Bosch Panel using RPS. This error typically pops up when trying to login with RPS and making the connection to the panel in RPS.
"Invalid or missing Hardware Key"
Steps:
1. Check to make sure that the USB dongle is inserted into the PC RPS is installed on
2. Install, repair or update the Sentinel Driver in Windows Programs and Features
- Navigate to Windows Programs and Features
- Right Click on the Sentinel Driver
- Select Repair
- Clicked through Next and Install
- Prompted to restart the PC
Note: Before restarting the PC, Exit RPS, Stop and Exit Docker, Exit Access Expert and then Restart the PC.
Once the restart is completed, restart RPS and connect the Bosch panel, there should not be an error with the hardware key. Restart Docker and Access Expert. The panel should show online in Access Expert.
Additional external reference from Bosch: