Issue
A method to remove access from a large number of Personnel by changing the Expiration Date using a Template.
Product Line
Andover Continuum
Environment
Continuum Access Control
Cause
Need to know how to disable large numbers of Personnel at one time using the Personnel Expiration Date.
Resolution
The Personnel Expiration Date is distributed down to the Controllers and used to allow or deny access at the Door. If a future date is set then the Personnel has normal access, if a past date has been set then they do not have access and a "Person Expiration Date Passed" error will be displayed when they are refused access. See the steps below on how to use a template to mass set this Expiration Date field for a large number of Personnel at the same time.
1. Create a Personnel Template in the Personnel Templates Folder. Notice that the Expiration Date defaults to a future date of "12/31/2099 11:59:59 AM".
2. Go to the Attribute Data Source tab and set the ExpirationDate attribute to InheritFromTemplate.
3. Use this Template to create your Personnel objects.
4. Notice that Personnel created from this template should show the Expiration Date in Blue which is also un-editable in the Details tab.
5. Edit the Template and change the Expiration Date to a date that has already past. After saving the Template the changes will be made to all attached Personnel and those Personnel distributed to all online controllers. Viewing the Distribution Properties, you should see an entry for each object refreshed by the Template.
6. Looking at the Access Distribution View you should see that the Personnel have been redistributed down to the controllers successfully.
7. Test your Personnel at the Door and they should no longer have access. Looking in an active Event View you can see that the Personnel are not being granted access with the Message "Person Expiration Date Passed". When setting the ExpirationDate back to a future time they will now have normal access.