Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84698members
354075posts

Need help with my 650

APC UPS for Home and Office Forum

Schneider Electric support forum for our APC offers including Home Office UPS, Surge Protectors, UTS, software and services and associated products designed to share knowledge, installation, and configuration.

Solved
Tab28_apc
Crewman
Crewman
0 Likes
7
214

Need help with my 650

This was originally posted on APC forums on 10/11/2012


The manual says B650MC. The problem is when I have a power outage. The backup does not go on, just a long constant beep. Also when the power does come back on; the unit itself needs to be turned off and turned back on, using the power button in order for items plugged in to get power. This is the main issue, this does not seem right even if battery needs replacing. Is this normal or a bad unit?

The unit is less than a year old, always been plugged in. The actual backup was only needed twice since installed. Both times no backup. I have been home both times, actually power was only loss for about 30 seconds each time and powers 2 water pumps less than 100 watts total.


Accepted Solutions
Tab28_apc
Crewman
Crewman
0 Likes
0
214

Re: Need help with my 650

This was originally posted on APC forums on 10/16/2012


On the bottom on the software it states there is 60 minutes of battery time. It also stated the unit was working, so I am not sure if I believe anything it says. When I first plugged in the unit it said there was over 400, but rested on the 60 minutes. I am guessing this is an estimate on wattage being used. If you are running a computer and moniter it would be less time than say the water pump I had plugged into it. That would be more than an hour since it would be far less wattage.

See Answer In Context

7 Replies 7
BillP
Administrator Administrator
Administrator
0 Likes
0
214

Re: Need help with my 650

This reply was originally posted by Chris on APC forums on 10/11/2012


It sounds like the unit may have an internal fault. Are you sure it's B650MC and not BK650MC?

Tab28_apc
Crewman
Crewman
0 Likes
0
214

Re: Need help with my 650

This was originally posted on APC forums on 10/12/2012


Yes I missed a letter but it is BE650MC.

BillP
Administrator Administrator
Administrator
0 Likes
0
214

Re: Need help with my 650

This reply was originally posted by Chris on APC forums on 10/15/2012


Is the led lit when this happens? The below description is for a replace battery indication. If there is no LED indication, this is an overload alarm. If it's overloading when it shouldn't be (low or no load), it's likely an internal fault with the unit and it needs to be replaced

Power On/Replace Battery
LED flashes alternately green
and red.

Tab28_apc
Crewman
Crewman
0 Likes
0
214

Re: Need help with my 650

This was originally posted on APC forums on 10/15/2012


Over the weekend I plugged the unit into my computer and ran the software. The unit is actually for backup on a water pump. The water pump is maybe 100 watts max. Anyway the software says the battery was at 100% and recharging. I plugged small fan to test the unit. And as soon as the A/C is cut the unit beeps a continuous beep and a red light but no backup for the fan. If you hit the power button twice the unit turned on the fan for maybe a second then it shut off and beeped again. After you turn the A/C back on you have hit the power button twice as before to get the unit to allow A/C to the lamp and a constant green on unit. I plugged the fan into every outlet on the backup side of the unit including the one marked as master none would battery backup.

When the unit is running on A/C the only light is a constant green. Although when you first turn it on, it does blink green for a short time before going constant green. The software has no indications that there is any issues with battery or the unit. I have much cheaper units the battery has lasted years and always worked when needed to. This unit the battery has never needed to run since an outage is rare. I never notice it not working. No beeping or lights in indicate there was a problem until now when the power did cut out on the wall.

BillP
Administrator Administrator
Administrator
0 Likes
0
214

Re: Need help with my 650

This reply was originally posted by Chris on APC forums on 10/15/2012


What is your runtime showing in the software?

Tab28_apc
Crewman
Crewman
0 Likes
0
214

Re: Need help with my 650

This was originally posted on APC forums on 10/15/2012


Are you speaking of the battery run time? I will have to look. There was a number in the lower right but I am not sure what it said or if it was stated in minutes or hours.

Tab28_apc
Crewman
Crewman
0 Likes
0
215

Re: Need help with my 650

This was originally posted on APC forums on 10/16/2012


On the bottom on the software it states there is 60 minutes of battery time. It also stated the unit was working, so I am not sure if I believe anything it says. When I first plugged in the unit it said there was over 400, but rested on the 60 minutes. I am guessing this is an estimate on wattage being used. If you are running a computer and moniter it would be less time than say the water pump I had plugged into it. That would be more than an hour since it would be far less wattage.