Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84670members
354060posts

EWS Server History Values in SmartConnector are showing incorrect value in EBO

SmartConnector Forum

Discussion of SmartConnector applications for integration of various other building management systems (BMS) into EcoStruxure Building Operation

SteveGregory
Commander Commander
Commander
0 Likes
4
692

EWS Server History Values in SmartConnector are showing incorrect value in EBO

I have a SmartConnector extension running in 2.5.4 with boolean type History records which appear correct when viewed in the SmartConnector portal, however; they are all reading 0 in EBO 4.0.1.86. See attached screen shot. 

Attachments
Tags (2)
4 Replies 4
ardak
Commander Commander
Commander

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Steven,

 

I've tested this and it looks like there's an issue with boolean serialization. It will be looked at ASAP.

 

BR

Armend

Tags (1)
SteveGregory
Commander Commander
Commander
0 Likes
2
511

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Just wondering if there is any update on this issue?

Tags (1)
ardak
Commander Commander
Commander
0 Likes
1
505

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Steve,

 

There's an issue in EBO where EBO's EWS client doesn't understand boolean trends from Smartconnector. I just got word that this will be fixed in 4.0.3. 

 

I'll probably add a "legacy serve" mode to Smartconnector that can be turned on to allow older EBO clients to be used. 

 

BR

Armend

Tags (1)
SteveGregory
Commander Commander
Commander
0 Likes
0
491

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Ardak,

Thanks for the update. If you have a version with this fix, happy to try it out. 

Steve

Tags (1)