Issue
When opening I/NET and getting an Initialization failure error and unable to log on to start the program.
Product Line
TAC INET
Environment
I/NET Revision 2.40 and higher on Windows 7 PCs.
Cause
There was a security update that disabled the Named Pipes and TCP/IP that is required for SQL to run.
Resolution
- Start , All Programs select Microsoft SQL 2005 or 2008
- Expand Configuration Tools and select SQL Server Configuration Manager
- Select SQL Native Client Configuration and expand it then click on Client Protocols
- Verify that TCP/IP and Named Pipes are enabled
- Click on SQL Server 2005 Network Configuration and click on Protocols for MSSQLSERVER
- Verify that Named Pipes and TCP/IP are enabled
- Open up Services and verify that SQL Agent, SQL Server and SQL Browser are all running and set to automatic.
- Start the I/O Configuration and verify that the connection is made to the correct database
- Restart I/NET again and it should allow you to start the program now.
For Remote Client with I/O Configuration:
- Repeat the above on SQL Server PC
- Ensure that port 50069, 1433 and 1434 are open between the PCs