Issue
Version 2.0a Error getting Key Id appears at bottom of the Hasp Key Utility when an attempt is made to activate the Continuum license using the v2c file.
Update failed: KeyIdNotFound
Product Line
Andover Continuum
Environment
- Continuum
- Keyless
- Soft License
- Hasp Key Utility
- Sentinel HASP License Manager
Cause
A defect has been identified with Sentinel's HASP Runtime executable prior to release 6.56 which can in some cases cause the Hasp key Utility's Key ID number to change each time the host machine is rebooted.
To determine if this is your issue run the following test:
- Launch the Hasp Key Utility executable in the Continuum program folder.
- Select Show Key Information.
- Note and record the Key ID #.
- Shut down the Hasp Key Utility and reboot the host machine.
- Relaunch the Hasp Key Utility and recheck the Key ID#.
Resolution
If the Key ID has changed following a reboot of the host machine, download the most recent version of the Continuum Software License Upgrade Utility from the Exchange Download Center.