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Collect logs from the Enterprise Server and Enterprise Central

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Collect logs from the Enterprise Server and Enterprise Central

Picard Product_Support
‎2018-09-06 03:56 PM

Last Updated: Guinan RobertAndriolo Guinan ‎2022-08-21 06:41 PM

Issue

When troubleshooting server issues, it can be helpful to look at the logs that are recorded within the Enterprise Server or Enterprise Central

Product Line

EcoStruxure Building Operation

Environment

  • Building Operation Enterprise Server
  • Building Operation Enterprise Central

Cause

Within the Enterprise Server and Enterprise Central logs are many records that are logged as a part of normal operations and unexpected events.

Resolution

Collect ES and EC Logs via EBO Workstation:

  1. Refer to the Workstation section of KB article: Collect logs from an Automation Server

Collect ES and EC Logs via Windows Explorer, especially if ES or EC will not run as a service or keep crashing:

  1. The ES or EC database path is listed in Software Administrator. 
    1.  For Windows 7, Server 2008, or higher, the default paths for the logs folder are:
      1. Enterprise Server: C:\ProgramData\Schneider Electric [EcoStruxure|StruxureWare]\Building Operation [n.n]\Enterprise Server\db\logs
      2. Enterprise Central: C:\ProgramData\Schneider Electric EcoStruxure\Building Operation [n.n]\Enterprise Central\db\logs
    2. In EBO V3.2 or higher, shortcut buttons can be found in Software Administrator to go to the folder for logs and database directly. Software Administrator Logs.png

       

    3. By default, the "Program Data" folder is hidden, so Windows needs to be configured to view hidden files and folders. For Windows 10 or 11, open Windows Explorer and select View > Show > Hidden items. For other Windows versions, please refer to this Microsoft help article: Show hidden files (microsoft.com).View hidden items.png
    4. Using Windows Explorer, Navigate to the ES or EC logs folder to find System and Trace logs.Logs folder.png
    5. Copy the Logs folder contents and send them to Product Support as a compressed file if required.
    6. To open a log file, Right-click on one of the logs and select Open with...
      Open With.png
    7. Expand the window and select WordPad.
      Open With Wordpad.png
    8. For Windows XP:
      23594i35F34DAC3DA18013.jfif
  •  

Other ways to review site-specific issues:

  1. Is the issue site-specific regarding workstation being used or applications/programs running on these machines? Always try to keep the programs on a workstation to a minimum.
  2. Review the Windows Event Logs. What specifically happens when an error occurs?
    Follow this KB article to view and save the Windows Events: Viewing, Saving, Sharing Windows Event Logs for Troubleshooting Purposes - Communities
  3. Make sure that PCs and Windows OS used for WorkStation, ES or EC meet the requirements mentioned in Information Technology System Planning Guide (se.com)
  4. Make sure that the firewall and antivirus are correctly configured, and required ports are open for EBO, as explained in Information Technology System Planning Guide (se.com)
  5. Make sure that the current installed EBO version is supported, as per the Software Support Policy for EcoStruxure Building Operation - PA-00300.
  6. Check if Microsoft currently supports the installed Windows OS: Lifecycle FAQ - Windows | Microsoft Docs
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