Issue
When troubleshooting server issues, it can be helpful to look at the logs that are recorded within the Enterprise Server or Enterprise Central
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Enterprise Server
- Building Operation Enterprise Central
Cause
Within the Enterprise Server and Enterprise Central logs are many records that are logged as a part of normal operations and unexpected events.
Resolution
Collect ES and EC Logs via EBO Workstation:
- Refer to the Workstation section of KB article: Collect logs from an Automation Server
Collect ES and EC Logs via Windows Explorer, especially if ES or EC will not run as a service or keep crashing:
- The ES or EC database path is listed in Software Administrator.
- For Windows 7, Server 2008, or higher, the default paths for the logs folder are:
- Enterprise Server: C:\ProgramData\Schneider Electric [EcoStruxure|StruxureWare]\Building Operation [n.n]\Enterprise Server\db\logs
- Enterprise Central: C:\ProgramData\Schneider Electric EcoStruxure\Building Operation [n.n]\Enterprise Central\db\logs
- In EBO V3.2 or higher, shortcut buttons can be found in Software Administrator to go to the folder for logs and database directly.
- By default, the "Program Data" folder is hidden, so Windows needs to be configured to view hidden files and folders. For Windows 10 or 11, open Windows Explorer and select View > Show > Hidden items. For other Windows versions, please refer to this Microsoft help article: Show hidden files (microsoft.com).
- Using Windows Explorer, Navigate to the ES or EC logs folder to find System and Trace logs.
- Copy the Logs folder contents and send them to Product Support as a compressed file if required.
- To open a log file, Right-click on one of the logs and select Open with...
- Expand the window and select WordPad.
- For Windows XP:
- For Windows 7, Server 2008, or higher, the default paths for the logs folder are:
Other ways to review site-specific issues:
- Is the issue site-specific regarding workstation being used or applications/programs running on these machines? Always try to keep the programs on a workstation to a minimum.
- Review the Windows Event Logs. What specifically happens when an error occurs?
Follow this KB article to view and save the Windows Events: Viewing, Saving, Sharing Windows Event Logs for Troubleshooting Purposes - Communities - Make sure that PCs and Windows OS used for WorkStation, ES or EC meet the requirements mentioned in Information Technology System Planning Guide (se.com)
- Make sure that the firewall and antivirus are correctly configured, and required ports are open for EBO, as explained in Information Technology System Planning Guide (se.com)
- Make sure that the current installed EBO version is supported, as per the Software Support Policy for EcoStruxure Building Operation - PA-00300.
- Check if Microsoft currently supports the installed Windows OS: Lifecycle FAQ - Windows | Microsoft Docs