Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84863members
354353posts

Netbotz 250 SNMPv3 authentication issue

EcoStruxure IT forum

A support forum for Data Center Operation, Data Center Expert, and EcoStruxure IT product users to share knowledge on installation, configuration, and general product use.

Solved
DCIM_Support
Picard
Picard
0 Likes
12
755

Netbotz 250 SNMPv3 authentication issue

This question was originally posted on DCIM Support by Brian Hobson on 2018-12-10


Hello! I've been able to get Netbotz and SNMP to work and can query for basic things such as the name of the device using the net-snmp linux command line tools. This works for both SNMPv1 and SNMPv3 (with no authentication) such as:

 

$ snmpget -v3 -l noAuthNoPriv -u "apc snmp profile2" 192.168.1.20 sysName.0 SNMPv2-MIB::sysName.0 = STRING: apc0D8DA9

 

 

However, when I try to enable authentication (I've tried MD5 and SHA) and set a passphrase, I receive a "Timeout: No Response from 192.168.1.20" error.

 

$ snmpget -v3 -l authNoPriv -u "apc snmp profile2" -a MD5 -A "PASSWORD1234567" 192.168.1.20 sysName.0 Timeout: No Response from 192.168.1.20.

 

I've tried switching profiles, changing MD5 and SHA, changing passwords, etc but so far I've been unsuccessful in getting SNMPv3 authentication working. Firmware version: v6.5.6. SNMPv1 and SNMPv3 are both enabled. In this test above 'apc snmp profile2' is enabled. Any assistance getting authentication working is appreciated!

 

Brian

 

(CID:137109973)

Tags (1)

Accepted Solutions
DCIM_Support
Picard
Picard
0 Likes
1
755

Re: Netbotz 250 SNMPv3 authentication issue

This answer was originally posted on DCIM Support by Brian Hobson on 2018-12-17


This issue appears to have been resolved by firmware update 6.6.7.

(CID:137725881)

See Answer In Context

12 Replies 12
DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by Brian Hobson on 2018-12-10


Update: I was able to get it to work by setting the passphrases through the web interface instead of through ssh. Does this make any sense? Is there a difference between the web admin interface  vs the ssh interface for configuring SNMP?

Brian

(CID:137110037)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by spezialist on 2018-12-10


Dear Brian Hobson,

Thanks for the update.

Can you show a screenshot from ssh CLI and from the web-GUI, as you exactly perform the above configuration of SNMPv3 authentication (this may be important) for NetBotz-250 device.

With respect.

(CID:137110104)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by Brian Hobson on 2018-12-11


Sure! The first screenshot shows that profile2 authentication is set to None before I set it to SHA using the ssh interface.

The next screenshot shows that the authentication mechanism has been set to SHA and shows my attempt to query for the system name using snmpget. The request shows a timeout error.

The last screenshot shows how I set the authentication to SHA using the web UI. After doing this, the same snmpget request works as expected.

 

Hope this helps, let me know if you need any further data.

 

Brian

(CID:137110401)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by spezialist on 2018-12-11


Dear Brian Hobson,

Many thanks for the detailed screenshots: this is probably a bug.

I hope that soon the Support team will pay attention to this.

With respect.

(CID:137110422)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by Brian Hobson on 2018-12-11


Thanks. Is there a place where I can submit a bug report or are you handling that process?

(CID:137110427)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by spezialist on 2018-12-11


Dear Brian Hobson,

Unfortunately, I do not know of such a special resource. Maybe Steven Marchetti or Stine Hansen knows?

With respect.

(CID:137110431)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by Steven Marchetti on 2018-12-11


Hi Folks,

The Resources menu and "feature requests" can also be used in case of a bug. I looked at this but have not yet tested it so I've not entered anything in the system.

 

Steve

(CID:137110441)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by Brian Hobson on 2018-12-11


Thanks Steve. I'll try to submit a request there and hopefully get a resolution.

Brian

(CID:137110462)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by Joshua Ellis on 2018-12-12


Hello,  Brian and I have spoken over email.  I did some testing and believe that this is a bug.  Seems as though the auth and priv passphrases are not being set over CLI, all other settings appear to work.  This is logged in our bug tracking tool and should hopefully be fixed soon.  If anyone has any questions please let me know.

Thanks.

(CID:137111337)

DCIM_Support
Picard
Picard
0 Likes
1
756

Re: Netbotz 250 SNMPv3 authentication issue

This answer was originally posted on DCIM Support by Brian Hobson on 2018-12-17


This issue appears to have been resolved by firmware update 6.6.7.

(CID:137725881)

DCIM_Support
Picard
Picard
0 Likes
0
755

Re: Netbotz 250 SNMPv3 authentication issue

This comment was originally posted on DCIM Support by spezialist on 2018-12-17


Ok, very thanks for the feedback.

(CID:137725928)

DCIM_Support
Picard
Picard
0 Likes
0
755

🔒 Closed

This question is closed for comments. You're welcome to start a new topic if you have further comments on this issue.