Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84323members
353487posts

IT Gateway - Docker container

EcoStruxure IT forum

A support forum for Data Center Operation, Data Center Expert, and EcoStruxure IT product users to share knowledge on installation, configuration, and general product use.

Gianluca
Lieutenant Lieutenant
Lieutenant

IT Gateway - Docker container

Hi All

 

a customer is deploying ITGateway in his Dockers container on hypervisor because for him, is the only way to have system stable and active

 

Container is based on CentOS 8 and processes are managed by supervisord - and not systemd

 

probably the initial options with which Tomcat is started are wrong, because:

 

- Show ports 8080 and 8009 and not the 443 that we are expect (among other things openVAS reports that the
version of Tomcat listening on these ports, which is that distributed with EcoStruxureITGateway 1.9.0.31, it is vulnerable)

 

- do not answers to pages they are in
/opt/EcoStruxureITGateway/1.9.0.31/apache-tomcat/webapps

 

how can we solve this?

 

thanks

Tags (1)
1 Reply 1
Arlington44
Cadet
0 Likes
0
726

Re: IT Gateway - Docker container

@mygiftcardsite wrote:

Hi All

 

a customer is deploying ITGateway in his Dockers container on hypervisor because for him, is the only way to have system stable and active

 

Container is based on CentOS 8 and processes are managed by supervisord - and not systemd

 

probably the initial options with which Tomcat is started are wrong, because:

 

- Show ports 8080 and 8009 and not the 443 that we are expect (among other things openVAS reports that the
version of Tomcat listening on these ports, which is that distributed with EcoStruxureITGateway 1.9.0.31, it is vulnerable)

 

- do not answers to pages they are in
/opt/EcoStruxureITGateway/1.9.0.31/apache-tomcat/webapps

 

how can we solve this?

 

thanks


Thanks for the information keep sharing such informative post keep suggesting such post.

 

Tags (1)