Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84547members
353802posts

[Imported] WebX Hand Control "not well-formed (invalid token)" error

EcoStruxure Geo SCADA Expert Forum

Find out how SCADA systems and networks, like EcoStruxure Geo SCADA Expert, help industrial organizations maintaining efficiency, processing data for smarter decision making with IoT, RTU and PLC devices.

Solved
sbeadle
Janeway Janeway
Janeway
0 Likes
1
373

[Imported] WebX Hand Control "not well-formed (invalid token)" error

>>Message imported from previous forum - Category:ClearSCADA Software<<
User: tcookson, originally posted: 2018-11-13 17:35:20 Id:317
I'm having an issue similar to, but not exactly like, the one described here: https://www.schneider-electric.us/en/faqs/FA275742/

If I follow the the FAQ note and add port 81, then mimics no longer display. In my case alarms/events/mimics all display correctly, but when I Hand Control a test internal point through WebX I get an error pop-up "not well-formed (invalid token)". WebX has control privileges in the web test folder, including the mimic I'm writing from and the point I'm trying to hand control.

System is ClearSCADA 2017 (Sept '17 update), running on Windows Server 2012.


Accepted Solutions
sbeadle
Janeway Janeway
Janeway
0 Likes
0
372

Re: [Imported] WebX Hand Control "not well-formed (invalid token)" error

>>Responses imported from previous forum


Reply From User: BevanWeiss, posted: 2019-01-03 21:59:34
Why would you change this from port 80 to port 81?
What port numbers (HTTP/HTTPS) is your WebX using?
NOTE: The FAQ is for "A common cause of these errors is the Original WebX being configured to use custom secure or non-secure ports". If you are not using 'custom secure or non-secure ports' then you should not have followed the directions in your link.


Reply From User: geoffpatton, posted: 2019-01-04 14:56:00
check the server configuration's WebX section and make sure Allow writes over HTTP is checked.


Reply From User: tcookson, posted: 2019-04-02 23:37:33
The check box states "Allow logon and database writes over ****non-secure ****HTTP.

I'd much prefer HTTPS, if possible.


Reply From User: sbeadle, posted: 2019-04-03 08:05:28
Client to web server communications are either HTTP or HTTPS, as configured within IIS. Web Server to ClearSCADA server communications are also configurable using HTTP or HTTPS, as configured in the IIS settings (referred in the FAQ) and Server Config tool WebX settings combined.
You can check the ClearSCADA server web port comms by enabling the WebX logging types in Server Status and reading the dbserver log files.


Reply From User: adamwoodland, posted: 2019-04-04 01:27:38
https://tprojects.schneider-electric.com/telemetry/CS/Diagnosing+Scripting+Connection+Errors may also help with your problem

See Answer In Context

1 Reply 1
sbeadle
Janeway Janeway
Janeway
0 Likes
0
373

Re: [Imported] WebX Hand Control "not well-formed (invalid token)" error

>>Responses imported from previous forum


Reply From User: BevanWeiss, posted: 2019-01-03 21:59:34
Why would you change this from port 80 to port 81?
What port numbers (HTTP/HTTPS) is your WebX using?
NOTE: The FAQ is for "A common cause of these errors is the Original WebX being configured to use custom secure or non-secure ports". If you are not using 'custom secure or non-secure ports' then you should not have followed the directions in your link.


Reply From User: geoffpatton, posted: 2019-01-04 14:56:00
check the server configuration's WebX section and make sure Allow writes over HTTP is checked.


Reply From User: tcookson, posted: 2019-04-02 23:37:33
The check box states "Allow logon and database writes over ****non-secure ****HTTP.

I'd much prefer HTTPS, if possible.


Reply From User: sbeadle, posted: 2019-04-03 08:05:28
Client to web server communications are either HTTP or HTTPS, as configured within IIS. Web Server to ClearSCADA server communications are also configurable using HTTP or HTTPS, as configured in the IIS settings (referred in the FAQ) and Server Config tool WebX settings combined.
You can check the ClearSCADA server web port comms by enabling the WebX logging types in Server Status and reading the dbserver log files.


Reply From User: adamwoodland, posted: 2019-04-04 01:27:38
https://tprojects.schneider-electric.com/telemetry/CS/Diagnosing+Scripting+Connection+Errors may also help with your problem